Umi and Satomi

シーズー犬うみと飼い主Satomiが楽しく生活してみます

Mac Yosemite に RMagick を入れてみました

Rails4で作っているプロジェクトで、Carrierwaveを使おうとすると、RMagickも一緒に使うことが多いかと思います。 それらのセットアップ時のトラブルです。

http://4.bp.blogspot.com/-8pKwZs0IJrQ/Tj0CR3UJu8I/AAAAAAAAAbA/-3yifInCr6w/s1600/crop_circle.jpg

エラーたち

bundle installが落ちる

$ bundle install --path vendor/bundle
----

An error occurred while installing rmagick (2.13.4), and Bundler cannot continue.
Make sure that `gem install rmagick -v '2.13.4'` succeeds before bundling.

↑なエラーが出ます。

gem install rmagick -v '2.13.4' が落ちる

$ gem install rmagick -v '2.13.4'
----

Fetching: rmagick-2.13.4.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
    ERROR: Failed to build gem native extension.

対応

$ brew install pkg-config
$ brew install imagemagick
$ gem install rmagick -v '2.13.4'
$ bundle install

↑これで通りました。 あらかたこれでうまくいくようですが、そうでないこともありますので、その際はエラー表示を読んで、ググって対応しなきゃですね。